Services degraded due to load unseen before
Incident Report for XRPL Labs, XUMM
Resolved
Connectivity & node availability has stabilised.
Posted Oct 31, 2021 - 17:32 CET
Update
We are continuing to monitor for any further issues.
Posted Oct 31, 2021 - 15:36 CET
Monitoring
The issues have been resolved by:
1. Blocking malicious requests sent by a concentrated group of IP addresses
2. Scaling up the cluster (yet again, this is an ongoing process but more capacity has been added at once)
3. Had to restart the geographic edge location for the cluster responsible for the Western European region (Falkenstein, Germany)

We are currently monitoring the situation.
Posted Oct 31, 2021 - 15:35 CET
Investigating
After receiving an abnormal (unseen before) amount of load to the cluster, we see both XRPL nodes and the cluster services responding late, or not at all. We are investigating these problems. In the meantime, using XUMM, you may encounter problems fetching transaction history and submitting transactions.

Please note your XRPL account, balance, transaction history and funds are fine. We're working to resolve this as soon as possible.
Posted Oct 31, 2021 - 15:03 CET
This incident affected: XRP Ledger - Public nodes (xrplcluster.com (XRPL Mainnet)).