Sign request resolve errors
Incident Report for XRPL Labs, XUMM
Postmortem

The Xumm API platform & backend was unable to reach the Redis pub/sub cluster, responsible for informing clients & API consumers about paload status updates. While the Redis cluster was onl offline for a brief period, when it came back, it was overloaded with retries, resulting in the cluster going down again.

The backend has been updated to cancel retry requests sooner (to prevent overloading the Redis cluster in case of downtime) & this scenario will be added to monitoring.

Posted Sep 10, 2023 - 10:29 CEST

Resolved
Due to a backend outage (Redis, PubSub) sign requests didn't receive status updates (opened, signed). This problem has been resolved, and monitoring will be improved to catch this type of outage in the future.
Posted Sep 10, 2023 - 10:26 CEST
This incident affected: XUMM API / SDK (XUMM Developer API/SDK).