Degraded public node availability (xrplcluster.com)
Incident Report for XRPL Labs, XUMM
Postmortem

After implementing control mechanisms on burst commands (queries) and the amount of queries per second & minute across all edge locations most high traffic users are not consuming resources from the XRPL nodes. Connectivity seems to have been fully restored for normal use.

Posted Apr 09, 2023 - 01:43 CEST

Resolved
The public XRP Ledger nodes (xrplcluster.com) are getting an unusual amount of traffic.

While control mechanisms like IP rate limiting and query filtering were already in place, the high traffic is not coming from a lot of new connections, but a lot of commands (queries) sent by a relatively low amount of connections. These commands saturate the XRPL nodes processing these queries.

As a result connectivity may be slow, limited or even unavailable. This can result in applications, wallets, etc. not being able to show your balance, transaction history, or trouble getting your signed transactions broadcasted to the XRP Ledger.

Please note that this is **not** a problem with the XRP Ledger itself: it is perfectly fine and reachable through other nodes, not under the amount of load xrplcluster.com is getting.
Posted Apr 03, 2023 - 08:30 CEST