Elevated XRP Ledger network fees
Incident Report for XRPL Labs, XUMM
Resolved
With the release of `rippled` 1.8.2 and sufficient validators updating to this version, a fix for the elevated fees was activated. The XRPL network fees are back to normal.

https://twitter.com/XRPLLabs/status/1473777566997692418
Posted Dec 23, 2021 - 10:28 CET
Monitoring
The XRP Ledger currently suffers from weird emergent behavior in the modules responsible for ledger size & fee escalation are keeping this situation from resolving itself due to a feedback loop between the two mechanisms.

As a result, transactions currently need a higher fee to make it into a newly closed ledger. While ledgers are being closed with low amount of transactions, the network fees are not coming down due to a badly designed fee escalation algorithm in the source code that powers the XRP Ledger (nodes).

While the fee escalation condition on the XRP Ledger *has not been* resolved, for XUMM end users problems are no longer noticeable as XUMM forces the network fees to be paid to be slightly elevated, causing transactions to go through.

Where the normal transaction fee used to be 12 drops (0.000012 XRP), this is currently forced to 150 drops (still only 0.00015 XRP).

The impact for end users is limited to paying the aforementioned higher XRP Ledger network fee on a per transaction basis.
Posted Dec 02, 2021 - 20:56 CET
This incident affected: XUMM API / SDK (XUMM Developer API/SDK) and XRP Ledger - Public nodes (xrplcluster.com (XRPL Mainnet)).