Backend unavailable for limited amount of Xumm app users
Incident Report for XRPL Labs, XUMM
Postmortem

After debugging a memory leak in the Xumm backend for the Xumm app, not all debugging settings were reverted after fixing the issue. The memory leak was caused by a third party downstream API serving unexpected large API results without the proper limits in place on the API consuming side.

Due to sticky load balancing, this issue affected 2% of the Xumm user base. The issue was brought to our attention within 2.5 hours & immediately fixed.

Posted Jun 07, 2023 - 12:41 CEST

Resolved
For a little over two hours, a very limited amount of App users encountered errors in the communication between the Xumm app and the Xumm backend, resulting in failure to open xApps and fetching payloads. The issue has been resolved.
Posted Jun 07, 2023 - 03:00 CEST