Timeout sending / confirming transaction submission
Incident Report for XRPL Labs, XUMM
Resolved
This incident has been resolved. Nodes part of xrplcluster.com falling behind will now be automatically taken out of the pool. Clients will be handed over to other nodes without clients noticing.
Posted Oct 31, 2021 - 13:34 CET
Monitoring
Some of the cluster's non full history nodes became isolated of the XRP Ledger. We're investigating what the cause of the problem was. By taking the isolated nodes out of the cluster, service has been restored for all users.

We will implement detection for this problem later today, and have this trigger automatic client handover to other, functional nodes. This way this type of problem can be fixed behind the scenes, without clients noticing.
Posted Oct 31, 2021 - 12:24 CET
This incident affected: XRP Ledger - Public nodes (xrplcluster.com (XRPL Mainnet)).